HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Wednesday 14th May 2025

Experiencing delays in callback

Update 17:55

The services are back to normal operations.

Update 18:34

The services are restored and operational. We are continuing to monitor the situation.

SUMMARY

The HID Origo Mobile Identities API is currently experiencing reduced functionality, resulting in delays in callback delivery. Our team is actively working to resolve the issue and will provide regular updates until it is fully addressed.

IMPACT

Administrators may experience delays in Mobile ID or Invitation Code management operations.

Mobile App users may experience issues redeeming Invitation Codes or receiving Mobile IDs.

Environment

Production | HID Origo Management Portal