HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Saturday 22nd August 2026

HID Origo Mobile Identities APIs are experiencing intermittent slowness and failures.

Update 22:56

  • The services are restore to operational and we're actively monitoring.

Update 21:56

  • We identified surges in API requests that caused service slowness and intermittent failures.

Summary

HID Origo Mobile Identities APIs are experiencing intermittent slowness and failures. Our team is actively investigating and working to restore normal service