HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Wednesday 20th November 2019

HID Origo Mobile Identities - Reduced Performance

Summary

The HID Origo Mobile Identities service is currently operating at reduced performance. Users may experience delays in status updated in the portal and callback events delivered via the API.

Services are expected to return to normal operations momentarily.

Impact

  • Mobile ID and device status may be delayed
  • Delivery of callback events may be delayed, but no events are lost

Environment

Production | HID Origo Management Portal


Update 18:11: Services are back to normal operations. Some status updates and callback events may still be delayed.

Update 20:39: All pending events have been processed.