HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Thursday 22nd April 2021

HID Origo Management Portal Intermittent Performance Issues

Summary

The HID Origo Management Portal service is intermittently operating at reduced performance.

Impact

Users might experience some slowness in the service.

Update 06:24 UTC

We are continuing to troubleshoot the issue.

Update 12:37 UTC

The problem has been identified and we are working on a resolution.

Update 13:08 UTC

Corrective action has been taken and the services are operational. We are continuing to monitor the situation.

Environment

Production | HID Origo Management Portal