HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Thursday 27th May 2021

HID Origo Management Portal HID Origo Services and Reader Manager Unavailable

SUMMARY

HID Origo Mobile Identities and Reader Manager are currently experiencing a service disruption. We are working to address the issue as soon as possible and will provide updates on an ongoing basis until resolved.

IMPACT

  • HID Origo Management Portal: Users may have problems logging in
  • HID Reader Manager Portal: Users may have problems logging in

Update 10:52

Corrective action has been taken and the services are operational. We are continuing to monitor the situation.

Update 11:59

The services are back to normal operations.

Environment

Production | HID Origo Management Portal