HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Friday 13th August 2021

Authentication HID Origo Authentication - Intermittent One Time Passwords (OTP) Issues

We are facing Intermittent One Time Password OTP issues in HID Origo, we are currently working to resolve the issue with the SMS gateway providers

Update 18/08/21 at 14:27 UTC We are working to restore the services as soon as possible.

Update 19/08/21 at 09:20 UTC We are working to restore the services as soon as possible.

Update 24/08/21 at 11:47 UTC We are working to restore the services as soon as possible.

Update 14/09/21 at 07:28 UTC The services are back to normal operations.